Regresar a la Pagina de Inicio

12 abr. 2010

funciones: maximo y promedio condicional

Un lector me hace llegar la siguiente inquietud via mail: dada una tabla, necesita calcular el maximo valor y el promedio.... de una persona en particular. Muestro algunos registros creados por mí para el ejemplo, evitando mostrar los datos que me hicieron llegar.
  en una celda se debera ingresar el nombre de la persona en cuestión, para que nuestras funciones calculen el maximo importe y el promedio.

4 comentarios:

Gonzalo dijo...

Hola. Me ayudó mucho este post. De todas maneras me surge una duda. Es posible usar esta fórmula dentro de otra? Por ej: =SI(B8=0;"";MIN(SI(M8:M33=AI8;B8:B33)))
Al utilizar CTRL+Shift+Enter el resultado es 0.
De no poder utilizarla tengo que utilizar columnas auxiliares
Gracias!

Damian Omar Silva dijo...

Yo creo que la solución seria combinar SI() con Y() para el caso de necesitar el uso de varias condiciones.
Por ejemplo: si(y(a1>0;b2=11;c1<=10);min(d1:d100))
Que seria: si a1 es mayor a ceros y b2 es igual a 11 y c1 es menor o igual a 10.... Entonces calculo el minimo del rango d1:d10.
Trata de adaptarlo a tu proyecto y cualquier cosa me avisas.

Jonathan Muñoz Solano dijo...

estoy intentando lo de este post en excel 2010 y me sale el error de valor.

detallo q mis columnas están separadas

Damian Omar Silva dijo...

Jonathan: si estás usando excel 2010, esa versión viene con =Promedio.si(rango; criterio), por cuanto no te haría falta el uso de una función matricial.
No comprendo bien lo que me decis con "columnas separadas", pero la función:
={MAX(SI(D2:D13=H1;E2:E13))}
le pide a Excel: si las celdas del rango D2:D13 coinciden con el valor presente en H1, entonces decime cual es el valor mas alto (MAX) del rango E2:E13. Seguramente tus datos están en otro lado, por cuanto deberías reemplazar los argumentos de mi ejemplo x los de tu proyecto.
Y no olvides presionar "ctrol + mayuscula + enter" al ingresar la función, para que se convierta en matricial (fijate que está encerrada entre llaves). si el error persiste, mandame tu archivo.
gracias x el mensaje

Publicar un comentario

Regresar a la Pagina de Inicio

ENTRADAS MAS RECIENTES (ULTIMAS 10)


las + vistas

10 ULTIMOS COMENTARIOS DE MIS LECTORES

Free counters!
blog de periodismo




GRAFICA RIO BRAVO
Serigrafia-Offset
Rosario - Santa Fe - Argentina
TE: 0341 4664028